Error ocurred while updating

Rated 4.56/5 based on 980 customer reviews

Can you try the following from the Anaconda prompt—which will create an isolated environment and install and run Spyder from it in DEBUG mode—and let us know if it works, and if not what output you receive: Hi @CAM-Gerlach, since I am facing the same error ("an error occurred while starting the kernel") while running a python command "import keras" in my newly installed anaconda env on windows 10, I have run the given above commands given by you as below: conda create -n spyder-env python=3.6 activate spyder-env conda install spyder set SPYDER_DEBUG=3 ========================= Proceed ([y]/n)?

error ocurred while updating-63

error ocurred while updating-9

error ocurred while updating-7

error ocurred while updating-9

Also, just to let you know, below are the relevant packages (found from the different forums/threads) as of now in my anaconda env: ipykernel = 5.1.0 pyzmq = 17.1.2 setuptools = 40.6.3 Let me know if I have downgrade any of these packages for fixing the issue.I also fixed the other problem that triggered the error (over in #7357 ) and couldn't repro it there either.The one thing is it seems every instance of it has to do with some low-level compiled code, either from Theano/Keras, Tensorflow, or MKL/Open MP.# packages in environment at C:\Anaconda3\envs\theano-test: # # Name Version Build Channel backcall 0.1.0 py36_0 certifi 20 py36_0 cloudpickle 0.6.1 py36_0 colorama 0.4.1 py36_0 decorator 4.3.0 py36_0 h5py 2.9.0 tornado 5.1.1 py36hfa6e2cd_0 traitlets 4.3.2 py36h096827d_0 vc 14.1 h0510ff6_4 vs2015_runtime 6 h3a45250_0 wcwidth 0.1.7 py36h3d5aa90_0 wheel 0.32.3 py36_0 wincertstore 0.2 py36h7fe50ca_0 zeromq 4.2.5 he025d50_1 pip uninstall --yes theano keras h5py numpy scipy pyyaml keras-applications keras-preprocessing conda install m2w64-toolchain mkl-service mkl=2018.0.2 numpy scipy h5py pyyaml pip install git git://github.com/Theano/pip install git git://github.com/fchollet/Again, I tested opening a new Spyder instance and console after each command, basic commands, numpy import and commands, and importing Theano and Keras (as appropriate for each), and retested everything above, which all worked, this time without all the warnings on import.# packages in environment at C:\Anaconda3\envs\theano-test: # # Name Version Build Channel backcall 0.1.0 py36_0 blas 1.0 mkl certifi 20 py36_0 cloudpickle 0.6.1 py36_0 colorama 0.4.1 py36_0 decorator 4.3.0 py36_0 h5py 2.9.0 py36h5e291fa_0 hdf5 1.10.4 h7ebc959_0 icc_rt 2019.0.0 h0cc432a_1 intel-openmp 2019.1 144 ipykernel 5.1.0 py36h39e3cac_0 ipython 7.2.0 py36h39e3cac_0 ipython_genutils 0.2.0 py36h3c5d0ee_0 jedi 0.13.2 py36_0 jupyter_client 5.2.4 py36_0 jupyter_core 4.4.0 py36_0 Keras 2.2.4 libpython 2.1 py36_0 libsodium 1.0.16 h9d3ae62_0 m2w64-binutils 2.25.1 5 m2w64-bzip2 1.0.6 6 m2w64-crt-git 5.0.0.4636.2595836 2 m2w64-gcc 5.3.0 6 m2w64-gcc-ada 5.3.0 6 m2w64-gcc-fortran 5.3.0 6 m2w64-gcc-libgfortran 5.3.0 6 m2w64-gcc-libs 5.3.0 7 m2w64-gcc-libs-core 5.3.0 7 m2w64-gcc-objc 5.3.0 6 m2w64-gmp 6.1.0 2 m2w64-headers-git 5.0.0.4636.c0ad18a 2 m2w64-isl 0.16.1 2 m2w64-libiconv 1.14 6 m2w64-libmangle-git 5.0.0.4509.2e5a9a2 2 m2w64-libwinpthread-git 5.0.0.4634.697f757 2 m2w64-make 4.1.2351.a80a8b8 2 m2w64-mpc 1.0.3 3 m2w64-mpfr 3.1.4 4 m2w64-pkg-config 0.29.1 2 m2w64-toolchain 5.3.0 7 m2w64-tools-git 5.0.0.4592.90b8472 2 m2w64-windows-default-manifest 6.4 3 m2w64-winpthreads-git 5.0.0.4634.697f757 2 m2w64-zlib 1.2.8 10 mingw 4.7 .0.2 1 mkl-service 1.1.2 py36hb217b18_4 mkl_fft 1.0.1 py36h452e1ab_0 mkl_random 1.0.1 py36h9258bd6_0 msys2-conda-epoch 20160418 1 numpy 1.14.3 py36h9fa60d3_1 numpy-base 1.14.3 py36h555522e_1 parso 0.3.1 py36_0 pickleshare 0.7.5 py36_0 pip 18.1 py36_0 prompt_toolkit 2.0.7 py36_0 pygments 2.3.1 py36_0 pyreadline 2.1 py36_1 python 3.6.8 h9f7ef89_0 python-dateutil 2.7.5 py36_0 pyyaml 3.13 py36hfa6e2cd_0 pyzmq 17.1.2 py36hfa6e2cd_0 scipy 1.1.0 py36h672f292_0 setuptools 40.6.3 py36_0 six 1.12.0 py36_0 spyder-kernels 1.0.1 py36_0 sqlite 3.26.0 he774522_0 Theano 1.0.4 4.gc72eafaff tornado 5.1.1 py36hfa6e2cd_0 traitlets 4.3.2 py36h096827d_0 vc 14.1 h0510ff6_4 vs2015_runtime 6 h3a45250_0 wcwidth 0.1.7 py36h3d5aa90_0 wheel 0.32.3 py36_0 wincertstore 0.2 py36h7fe50ca_0 yaml 0.1.7 hc54c509_2 zeromq 4.2.5 he025d50_1 zlib 1.2.11 h62dcd97_3 # packages in environment at C:\Anaconda3\envs\theano-test: # # Name Version Build Channel _tflow_select 2.2.0 eigen absl-py 0.7.0 py36_0 astor 0.7.1 py36_0 backcall 0.1.0 py36_0 blas 1.0 mkl ca-certificates 2018.12.5 0 certifi 20 py36_0 cloudpickle 0.6.1 py36_0 colorama 0.4.1 py36_0 decorator 4.3.0 py36_0 gast 0.2.2 py36_0 grpcio 1.16.1 py36h351948d_1 h5py 2.9.0 py36h5e291fa_0 hdf5 1.10.4 h7ebc959_0 icc_rt 2019.0.0 h0cc432a_1 intel-openmp 2019.1 144 ipykernel 5.1.0 py36h39e3cac_0 ipython 7.2.0 py36h39e3cac_0 ipython_genutils 0.2.0 py36h3c5d0ee_0 jedi 0.13.2 py36_0 jupyter_client 5.2.4 py36_0 jupyter_core 4.4.0 py36_0 keras 2.2.4 0 keras-applications 1.0.6 py36_0 keras-base 2.2.4 py36_0 keras-preprocessing 1.0.5 py36_0 libgpuarray 0.7.6 hfa6e2cd_0 libprotobuf 3.6.1 h7bd577a_0 libpython 2.1 py36_0 libsodium 1.0.16 h9d3ae62_0 m2w64-binutils 2.25.1 5 m2w64-bzip2 1.0.6 6 m2w64-crt-git 5.0.0.4636.2595836 2 m2w64-gcc 5.3.0 6 m2w64-gcc-ada 5.3.0 6 m2w64-gcc-fortran 5.3.0 6 m2w64-gcc-libgfortran 5.3.0 6 m2w64-gcc-libs 5.3.0 7 m2w64-gcc-libs-core 5.3.0 7 m2w64-gcc-objc 5.3.0 6 m2w64-gmp 6.1.0 2 m2w64-headers-git 5.0.0.4636.c0ad18a 2 m2w64-isl 0.16.1 2 m2w64-libiconv 1.14 6 m2w64-libmangle-git 5.0.0.4509.2e5a9a2 2 m2w64-libwinpthread-git 5.0.0.4634.697f757 2 m2w64-make 4.1.2351.a80a8b8 2 m2w64-mpc 1.0.3 3 m2w64-mpfr 3.1.4 4 m2w64-pkg-config 0.29.1 2 m2w64-toolchain 5.3.0 7 m2w64-tools-git 5.0.0.4592.90b8472 2 m2w64-windows-default-manifest 6.4 3 m2w64-winpthreads-git 5.0.0.4634.697f757 2 m2w64-zlib 1.2.8 10 mako 1.0.7 py36_0 markdown 3.0.1 py36_0 markupsafe 1.1.0 py36he774522_0 mingw 4.7 .0.2 1 mkl-service 1.1.2 py36hb217b18_4 mkl_fft 1.0.1 py36h452e1ab_0 mkl_random 1.0.1 py36h9258bd6_0 msys2-conda-epoch 20160418 1 numpy 1.14.3 py36h9fa60d3_1 numpy-base 1.14.3 py36h555522e_1 openssl 1.1.1a he774522_0 parso 0.3.1 py36_0 pickleshare 0.7.5 py36_0 pip 18.1 py36_0 prompt_toolkit 2.0.7 py36_0 protobuf 3.6.1 py36h33f27b4_0 pygments 2.3.1 py36_0 pygpu 0.7.6 py36h452e1ab_0 pyreadline 2.1 py36_1 python 3.6.8 h9f7ef89_0 python-dateutil 2.7.5 py36_0 pyyaml 3.13 py36hfa6e2cd_0 pyzmq 17.1.2 py36hfa6e2cd_0 scipy 1.1.0 py36h672f292_0 setuptools 40.6.3 py36_0 six 1.12.0 py36_0 spyder-kernels 1.0.1 py36_0 sqlite 3.26.0 he774522_0 tensorboard 1.12.2 py36h33f27b4_0 tensorflow 1.12.0 eigen_py36h67ac661_0 tensorflow-base 1.12.0 eigen_py36h45df0d8_0 termcolor 1.1.0 py36_1 theano 1.0.3 py36_0 tornado 5.1.1 py36hfa6e2cd_0 traitlets 4.3.2 py36h096827d_0 vc 14.1 h0510ff6_4 vs2015_runtime 6 h3a45250_0 wcwidth 0.1.7 py36h3d5aa90_0 werkzeug 0.14.1 py36_0 wheel 0.32.3 py36_0 wincertstore 0.2 py36h7fe50ca_0 yaml 0.1.7 hc54c509_2 zeromq 4.2.5 he025d50_1 zlib 1.2.11 h62dcd97_3 @v1llum We're not sure exactly what is causing this, but it seems like it could be something low-level on your machine.

Leave a Reply